Check engine light ZX6R 19 - ZX6R Forum
 7Likes
  • 2 Post By RJ2112
  • 1 Post By Gawernator
  • 1 Post By Kubetsu
  • 1 Post By Kubetsu
  • 2 Post By DustoffNinja
 
LinkBack Thread Tools Display Modes
post #1 of 15 Old 05-16-2019, 02:28 PM Thread Starter
Squid
 
Join Date: May 2019
Posts: 2
Check engine light ZX6R 19

So, while doing my fender eliminator and my integrated taillight. My check engine light popped up because one of the servo switches popped off the clip and when I went to test the twilight for left and right signals the CE light was on.

I have tried taking the battery off the terminals, and I have tried touching the positive and negative terminals together for 20 seconds to release the charge.

The dealership wants to charge me an hour to connect the machine to it and reset the code. (100$) how do I reset the code myself...
SirVeldy is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 05-16-2019, 05:30 PM
Post Master General
 
RJ2112's Avatar
 
Join Date: Apr 2012
Location: Bowling Green, VA
Posts: 11,459

I Ride: '09 ZX6R
I suspect the '19+ models have CANBUS data systems, like many cars have. This would make it more difficult to alter lighting, and other electronic devices, as there is typically communication between the devices. Which may use the D.C. power wiring to do so......

Older setups are 'dumb'; they never notice changes. If the aftermarket hasn't changed their design to adapt to the new configuration, it is much more likely to have faults with the '19 that wouldn't show for previous years.
Gawernator and KawasakiBrad like this.

"Basic stuff fellas. Use your head for something other than to break your next fall."
RJ2112 is online now  
post #3 of 15 Old 05-16-2019, 05:35 PM
MotoGP Champion
 
Gawernator's Avatar
 
Join Date: Sep 2015
Location: Brentwood, CA
Posts: 2,819

I Ride: 2015 ZX-6R; 1999 KX125; 2002 BMW R1150RT
Garage
Quote:
Originally Posted by SirVeldy View Post
So, while doing my fender eliminator and my integrated taillight. My check engine light popped up because one of the servo switches popped off the clip and when I went to test the twilight for left and right signals the CE light was on.

I have tried taking the battery off the terminals, and I have tried touching the positive and negative terminals together for 20 seconds to release the charge.

The dealership wants to charge me an hour to connect the machine to it and reset the code. (100$) how do I reset the code myself...
With my woolich system I can see, and reset ECU error codes. Otherwise I think you need the dealer tool. definitely not worth $100.
DillyD likes this.

Watchdog Armory Racing AFM #725 Thanks to my 2018 Sponsors:
JPH Suspension | AXO Racing | Armour Bodies | | EVLUTION Nutrition | Forcefield Armor | Galfer | Motion Pro | MOTUL | Matrix Racing Concepts | ODI Grips | OGIO | Shorai Inc. | Vortex | Woodcraft | Wicked Audio
http://www.gawerracing.com
Gawernator is offline  
Sponsored Links
Advertisement
 
post #4 of 15 Old 05-18-2019, 07:24 PM
Squid
 
Kubetsu's Avatar
 
Join Date: May 2019
Posts: 6
Maaaaan - I just did the same. Fender Eliminator & Integrated tail light from TST and I got an CE Light. I just ordered a Flasher Relay to see if that fixes the issue.

Were you able to figure out how to fix yours?

Last edited by Kubetsu; 05-18-2019 at 11:28 PM.
Kubetsu is offline  
post #5 of 15 Old 05-18-2019, 07:51 PM
Post Master General
 
Scorpi0's Avatar
 
Join Date: Feb 2012
Location: LA, Cali
Posts: 11,793

I Ride: 06 636
Is there a check engine light on the 2019 models separate from the FI light?

If its just the FI light, u should be able to read the code.
Scorpi0 is offline  
post #6 of 15 Old 05-18-2019, 11:14 PM
Squid
 
Kubetsu's Avatar
 
Join Date: May 2019
Posts: 6
Yeah, there’s an actual check engine light.
**I just realized I said FI light, meant CE. Edited. 🙂

Last edited by Kubetsu; 05-18-2019 at 11:29 PM.
Kubetsu is offline  
post #7 of 15 Old 05-19-2019, 03:59 AM
Squid
 
DustoffNinja's Avatar
 
Join Date: May 2019
Location: Honolulu, HI
Posts: 10

I Ride: 2019 ZX-6R KRT
Garage
I'm about to be installing a yoshimura fender eliminator, I'm understanding that the stock rear light has led's, so am I correct to assume you don't need to put a resistor on for that integrated tail light, or led turn signals?
DustoffNinja is offline  
post #8 of 15 Old 05-19-2019, 04:09 AM
Post Master General
 
RJ2112's Avatar
 
Join Date: Apr 2012
Location: Bowling Green, VA
Posts: 11,459

I Ride: '09 ZX6R
Quote:
Originally Posted by DustoffNinja View Post
I'm about to be installing a yoshimura fender eliminator, I'm understanding that the stock rear light has led's, so am I correct to assume you don't need to put a resistor on for that integrated tail light, or led turn signals?
Because no one here knows, it would be great if you asked yoshimura that...... Please let us know what they say.

"Basic stuff fellas. Use your head for something other than to break your next fall."
RJ2112 is online now  
post #9 of 15 Old 05-19-2019, 09:36 AM
Squid
 
chris#55's Avatar
 
Join Date: Apr 2019
Location: South Germany
Posts: 10

I Ride: `19 ZX6R 636
That flasher relay should do it, unless there´s also a other issue.
I installed led indicators at the rear on mine with a flaher relay, no CE.
Quote:
Originally Posted by Kubetsu View Post
Maaaaan - I just did the same. Fender Eliminator & Integrated tail light from TST and I got an CE Light. I just ordered a Flasher Relay to see if that fixes the issue.

Were you able to figure out how to fix yours?
chris#55 is offline  
post #10 of 15 Old 05-19-2019, 08:35 PM Thread Starter
Squid
 
Join Date: May 2019
Posts: 2
Yes, I picked it up from the dealer after my first service, the service manager told me that there was no way I could do it myself and I should just give him the 100$ to do it.

I promptly walked right out and went into the parking lot took my terminals off of the battery, touched them together for 20 seconds, hooked them back up, got on the bike. Rode for 20miles. Did the same thing when I stopped at this place, terminals off touch for 20mins, my bike then sat for about 2 hours and when I got back on and started it up the check engine light was gone.

TLDR: take terminals off, touch them together for 20secs, wait a couple hours. Tadaaa. Gotta make sure the reason your check Engine light popped is fixed though.
SirVeldy is offline  
post #11 of 15 Old 05-19-2019, 11:00 PM
Squid
 
DustoffNinja's Avatar
 
Join Date: May 2019
Location: Honolulu, HI
Posts: 10

I Ride: 2019 ZX-6R KRT
Garage
Yeah I'll ask yoshimura when they open up.
DustoffNinja is offline  
post #12 of 15 Old 05-23-2019, 12:22 PM
Squid
 
Kubetsu's Avatar
 
Join Date: May 2019
Posts: 6
All alright, so I pulled to the code - took some playing around. So on the 19 zx6r. you have to push both the Menu button & Reset button on the gauges to show the code. Got code 34 - I'm guessing I tested the turn signals before plugging the Servo back in. For now, I'm just going to ride it around with the CE until I buy an exhaust & servo buddy.
Gawernator likes this.
Kubetsu is offline  
post #13 of 15 Old 05-23-2019, 12:25 PM
Squid
 
Kubetsu's Avatar
 
Join Date: May 2019
Posts: 6
Quote:
Originally Posted by chris#55 View Post
That flasher relay should do it, unless there´s also a other issue.
I installed led indicators at the rear on mine with a flaher relay, no CE.
All the turn signals are still traditional bulbs. You'll need a relay - check out TST Industries, they make a nice set. I got the license plate light, integrated tail light, fender eliminator and relay for less than $200.
Gawernator likes this.
Kubetsu is offline  
post #14 of 15 Old 05-23-2019, 06:32 PM
Squid
 
HapaNinja's Avatar
 
Join Date: Mar 2019
Posts: 2
I had the same issue with the check engine light right after I installed my fender eliminator and two brothers exhaust. If you mess with the servo and butterfly valve you have to install

Servo Buddy 42-1112 FI Light Exhaust Valve Servo Eliminator for Kawasaki and Suzuki https://www.amazon.com/dp/B00BSXDV40..._2I05CbRFXV9A8

After I installed the Servo Buddy the check engine light turned off after about 100 miles. I also just installed TST integrated tail light and the check engine has not turned on. Hopefully this helps. I have a 2019 ZX6R with ABS.
HapaNinja is offline  
post #15 of 15 Old 05-24-2019, 07:39 PM
Squid
 
DustoffNinja's Avatar
 
Join Date: May 2019
Location: Honolulu, HI
Posts: 10

I Ride: 2019 ZX-6R KRT
Garage
Quote:
Originally Posted by RJ2112 View Post
Quote:
Originally Posted by DustoffNinja View Post
I'm about to be installing a yoshimura fender eliminator, I'm understanding that the stock rear light has led's, so am I correct to assume you don't need to put a resistor on for that integrated tail light, or led turn signals?
Because no one here knows, it would be great if you asked yoshimura that...... Please let us know what they say.
The fender eliminator from yoshimura didn't come with the aftermarket led turn signals as I had originally thought. They came with brackets to use the stock lights. So no CE light, easy install.
RJ2112 and Gawernator like this.
DustoffNinja is offline  
Reply

  ZX6R Forum > ZX6R Forum > The ZX6R

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 ZX6R 636 Engine Stall Kawaii636 Mechanical and Technical 5 05-22-2019 01:32 AM
Anyone know how to clear engine codes on 2019 zx6r? Dreamland37 The ZX6R 1 03-16-2019 02:17 AM
'13 ZX6R Engine Light on madmax31 Mechanical and Technical 4 01-05-2019 12:42 PM
ZX6R 2010 wont start fi light on no fuel pump sound kawaz550gp Mechanical and Technical 2 11-15-2018 02:11 PM
95 zx6r engine spoony Want to Buy 1 01-24-2009 07:18 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome