zx6r 2009 Cooling fan not workin - ZX6R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-13-2019, 11:23 AM Thread Starter
Squid
 
Join Date: May 2019
Posts: 2
Question zx6r 2009 Cooling fan not workin

Hi, Zx6R when temperature go up until 110C cooling fan don't turn on, so i hook up the fan directly to the battery he works. So why don't turn on when temperature goes up 100 C ?
Donatas is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-13-2019, 06:15 PM
Post Master General
 
RJ2112's Avatar
 
Join Date: Apr 2012
Location: Bowling Green, VA
Posts: 11,323

I Ride: '09 ZX6R
Quote:
Originally Posted by Donatas View Post
Hi, Zx6R when temperature go up until 110C cooling fan don't turn on, so i hook up the fan directly to the battery he works. So why don't turn on when temperature goes up 100 C ?
The shop manual for your bike should say what coolant temperature should start the fan.

There is a relay to switch it on.

Some part of that chain is broken.

The temperature sensor sends a signal to the ECU. Since you get a temp reading, we can presume that part works.

The ECU should have a command signal that should energize the coil of the relay, to close the power lead to the fan motor.

The fan motor will not run, unless the other side of the motor completes the circuit. It must make a connection with the other pole of the battery.

The relay may be bad. The command signal from the ECU may be blocked. The ground connection may be corroded.

Clean off any corrosion on all of the electrical connections. Rust has resistance. That stops current from flowing. Make sure the ground connection is just as clean.

"Basic stuff fellas. Use your head for something other than to break your next fall."
RJ2112 is online now  
post #3 of 4 Old 05-15-2019, 01:17 AM Thread Starter
Squid
 
Join Date: May 2019
Posts: 2
[QUOTE=RJ2112;1822048]

The relay may be bad. The command signal from the ECU may be blocked. The ground connection may be corroded.

Where I can find that relay on bike? how it looks?
Donatas is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 05-15-2019, 01:33 AM
Post Master General
 
RJ2112's Avatar
 
Join Date: Apr 2012
Location: Bowling Green, VA
Posts: 11,323

I Ride: '09 ZX6R
It's near the ECU. It should be shown on a parts diagram 27002A

You will need to compare the wiring diagram to identify which pins are involved.

"Basic stuff fellas. Use your head for something other than to break your next fall."
RJ2112 is online now  
Reply

  ZX6R Forum > ZX6R Forum > The ZX6R

Tags
fan

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 zx6r odd issue with cooling temp slawson12 Mechanical and Technical 12 04-02-2019 08:15 AM
2009 zx6r won’t start Jsepulveda19 The ZX6R 21 10-11-2018 05:45 PM
Finally tuned my 2009 zx6r rogal88 The ZX6R 8 07-30-2018 07:39 PM
2009 ZX6R to 636 Swap ZeeEx6Are New Member Introductions 0 06-16-2018 08:44 PM
07 zx6r fan/ cooling problem!! joelh82 Mechanical and Technical 15 04-29-2011 07:16 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome