19 zx6r servo - ZX6R Forum
 6Likes
  • 1 Post By Scorpi0
  • 3 Post By RJ2112
  • 2 Post By chris#55
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 03-15-2019, 09:42 PM Thread Starter
Squid
 
FallenPro's Avatar
 
Join Date: Mar 2019
Posts: 3
19 zx6r servo

Hey guys. I have a 2019 zx6r. A few days ago I purchased and installed a Yoshimura r77 slip on exhaust from revzilla. The exhaust fits okay but the hardware I was given to install on the servo did not fit so my check engine light code 34 is on because of it. Frustrated, I searched online for a solution. Again from revzilla I purchased a servo buddy to plug in in place of the servo to make my check engine light disappear. It did not. Even resetting the codes did not clear it. Does anybody have any advice for me on what to do to get my check engine light off or to why the servo buddy does not work for my 19 zx6r??
FallenPro is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 03-15-2019, 09:47 PM
Post Master General
 
Scorpi0's Avatar
 
Join Date: Feb 2012
Location: LA, Cali
Posts: 11,626

I Ride: 06 636
Servo buddy should have worked. Maybe u got a defect??

What happens if u completely disconnect the servo?
Scorpi0 is offline  
post #3 of 9 Old 03-15-2019, 09:59 PM Thread Starter
Squid
 
FallenPro's Avatar
 
Join Date: Mar 2019
Posts: 3
With nothing connected the check engine light remains on
FallenPro is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 03-15-2019, 10:08 PM
MotoGP Champion
 
jd41's Avatar
 
Join Date: Apr 2015
Location: Monterey, California
Posts: 5,321

I Ride: 2014 Kawasaki ZX-6R, 2013 Kawasaki Ninja 300
Garage
What if you disconnect and reconnect the battery?

JL99
jd41 is offline  
post #5 of 9 Old 03-15-2019, 10:11 PM Thread Starter
Squid
 
FallenPro's Avatar
 
Join Date: Mar 2019
Posts: 3
Quote:
Originally Posted by jd41 View Post
What if you disconnect and reconnect the battery?
With the servo buddy on I disconnected the battery for 10 minutes and reconnected it. My clock reset but the engine light code 34 came back on
FallenPro is offline  
post #6 of 9 Old 03-15-2019, 10:45 PM
Post Master General
 
Scorpi0's Avatar
 
Join Date: Feb 2012
Location: LA, Cali
Posts: 11,626

I Ride: 06 636
Well, your only options are a servo limiter and a servo buddy.

All I can say is maybe they sent u the wrong one, so try again. If it worked for anyone with a 2013-2018 then it should work for the 2019. Its the same bike.
Gawernator likes this.
Scorpi0 is offline  
post #7 of 9 Old 04-02-2019, 09:15 PM
Squid
 
HemiDave's Avatar
 
Join Date: Mar 2019
Location: New York
Posts: 13

I Ride: 2018 Suzuki GSXR 1000R.........2019 Ninja ZX6R 636
Garage
I just installed a Yoshi Alpha T slip-on exhaust this past weekend.

I used the servo hardware provided by Yoshi (2 pieces) to limit the servo rotation.

Worked like a charm....no check engine light.

Did you start the bike before finishing the install?
Attached Thumbnails
Click image for larger version

Name:	fullsizeoutput_2317.jpeg
Views:	18
Size:	1.04 MB
ID:	93408  

Click image for larger version

Name:	uP7KW2rrQxaEuLvL+x2uGw.jpg
Views:	15
Size:	2.39 MB
ID:	93442  

Click image for larger version

Name:	4FTvjLXNR2O%TwULJFcGpg.jpg
Views:	11
Size:	1.80 MB
ID:	93444  


2018 GSXR 1000R
2019 ZX6R 636
2016 392 Scat Pack Charger
2018 Dodge Demon
2019 Wide Body Scat Pack Challenger (6 speed manual)

Last edited by HemiDave; 04-05-2019 at 05:12 AM.
HemiDave is offline  
post #8 of 9 Old 04-03-2019, 03:10 AM
Post Master General
 
RJ2112's Avatar
 
Join Date: Apr 2012
Location: Bowling Green, VA
Posts: 11,305

I Ride: '09 ZX6R
Quote:
Originally Posted by FallenPro View Post
Hey guys. I have a 2019 zx6r. A few days ago I purchased and installed a Yoshimura r77 slip on exhaust from revzilla. The exhaust fits okay but the hardware I was given to install on the servo did not fit so my check engine light code 34 is on because of it. Frustrated, I searched online for a solution. Again from revzilla I purchased a servo buddy to plug in in place of the servo to make my check engine light disappear. It did not. Even resetting the codes did not clear it. Does anybody have any advice for me on what to do to get my check engine light off or to why the servo buddy does not work for my 19 zx6r??
It sounds like Kawasaki has changed the ECU and servo design from previous years. The physical servo stops have been needed in Europe's versions for some time rather than just disconnecting the cables and leaving the servo wired into the harness.

I'd expect you would need to use the stops, and retain the servo installed to the harness. You would likely need to disassemble the servo and reset it. If you turned on the ignition without the cables controlling the butterfly valve connected, it probably rotated completely through the expected range.
Gawernator, HemiDave and Bcraven22 like this.

"Basic stuff fellas. Use your head for something other than to break your next fall."
RJ2112 is offline  
post #9 of 9 Old 04-25-2019, 01:55 PM
Squid
 
chris#55's Avatar
 
Join Date: Apr 2019
Location: South Germany
Posts: 4

I Ride: `19 ZX6R 636
I threw out the whole servo on mine. I used the "Healtech Exhaust Servo Eleminator" on the remaining servo harness, works perfectly, no check engine light.
A slight bonus on the side, you actually got a little space now under the pillion seat.


Scorpi0 and HemiDave like this.
chris#55 is offline  
Reply

  ZX6R Forum > ZX6R Forum > The ZX6R




Similar Threads
Thread Thread Starter Forum Replies Last Post
How to: DIY Servo Remover Chaos Guides 227 08-20-2012 07:58 PM
Servo Buddy brussell512 Mechanical and Technical 7 06-09-2012 12:10 PM
Servo Removal Tutorial lil636 Mechanical and Technical 5 09-22-2011 09:17 PM
****Motor Electric aka Servo Motor**** ZX6R_C1H The ZX6R 0 06-10-2009 06:19 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome