Zx6r 05- no electric to fuel pump or injector - Page 3 - ZX6R Forum
 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 45 Old 03-10-2019, 09:10 AM Thread Starter
Squid
 
TheSkimbz's Avatar
 
Join Date: Jul 2018
Posts: 26
I tryed to contact him, not answering.. Maybe he calls back..
TheSkimbz is offline  
Sponsored Links
Advertisement
 
post #32 of 45 Old 03-10-2019, 09:13 AM Thread Starter
Squid
 
TheSkimbz's Avatar
 
Join Date: Jul 2018
Posts: 26
If someone knows can it bypass im interested to hear..
TheSkimbz is offline  
post #33 of 45 Old 03-10-2019, 09:23 AM
Post Master General
 
Scorpi0's Avatar
 
Join Date: Feb 2012
Location: LA, Cali
Posts: 11,682

I Ride: 06 636
Random question: Since youre from Finland.....Do u ever watch the Beyond the Press channel?
Scorpi0 is offline  
Sponsored Links
Advertisement
 
post #34 of 45 Old 03-10-2019, 09:33 AM
Squid
 
Join Date: Apr 2017
Posts: 55

I Ride: ZX6R 2006
Zx6r 05- no electric to fuel pump or injector

The ecu key and ignition is a matched set. If it does work when you switch all of them over you have a problem with unmatched key/ecu. The immobilizer is only an antenna and does not need to be matched.
Regarding bypassing, i have not found any way to do that, so a new set is needed. The red key is a master key, needed for recoding new keys and recoding a new ecu (which have to be completely new and cost about 1000 euros).

Regarding the FI light, you can put the bike in a dealer diagnosing mode (search here on the forum on how) and read out a code for what is wrong.
Also pick up the service manual here if you haven’t already.

Last edited by hehy; 03-10-2019 at 09:36 AM.
hehy is offline  
post #35 of 45 Old 03-10-2019, 10:35 AM Thread Starter
Squid
 
TheSkimbz's Avatar
 
Join Date: Jul 2018
Posts: 26
No 🙄🤣
TheSkimbz is offline  
post #36 of 45 Old 03-10-2019, 10:53 AM
Squid
 
Join Date: Apr 2017
Posts: 55

I Ride: ZX6R 2006
You can however buy a used set (ignition, ecu, keys, tank lock and Seat lock). If you can find a set that is.
hehy is offline  
post #37 of 45 Old 03-10-2019, 10:59 AM Thread Starter
Squid
 
TheSkimbz's Avatar
 
Join Date: Jul 2018
Posts: 26
How can i be sure that its immobilizer? Im building stunt bike.. So if i dont need ignition switch its enought to buy us ecu box?
TheSkimbz is offline  
post #38 of 45 Old 03-10-2019, 11:00 AM Thread Starter
Squid
 
TheSkimbz's Avatar
 
Join Date: Jul 2018
Posts: 26
Its didnt worked with my primary bike ignition switch and master key + antenna.. Fi light keeo flashing all the time when power is on
TheSkimbz is offline  
post #39 of 45 Old 03-10-2019, 12:34 PM Thread Starter
Squid
 
TheSkimbz's Avatar
 
Join Date: Jul 2018
Posts: 26
It works now!!! It was immobilizer.. Can anyone show me link for ecu box without immobilizer? Is there different part number for ecu box with immobilizer and without immobilizer
TheSkimbz is offline  
post #40 of 45 Old 03-10-2019, 01:19 PM
Squid
 
Join Date: Apr 2017
Posts: 55

I Ride: ZX6R 2006
There is a different part number for the EU and US ECU.
US version: 21175-0057
EU version (with imobilizer): 21175-0046

This would have to be bought alongside a new US ecu and harness i think
https://www.hsbkracing.com/parts-and...ness-assembly/
hehy is offline  
post #41 of 45 Old 03-11-2019, 06:30 AM
MrZ
World Superbike Racer
 
MrZ's Avatar
 
Join Date: Nov 2011
Location: Athens / Greece
Posts: 1,476

I Ride: my sexy Julia
Garage
Quote:
Originally Posted by hehy View Post
Regarding bypassing, i have not found any way to do that,
Because "how to bypass the immobiliser = how to steal a bike"
Quote:
Originally Posted by hehy View Post
This would have to be bought alongside a new US ecu and harness i think
Correct, US ecu works with US harness.
MrZ is offline  
post #42 of 45 Old 03-26-2019, 11:51 AM
Squid
 
Join Date: Jul 2014
Location: caifornia
Posts: 39
It could easily be a dead relay. On my bike there are several relays, headlight, starter and one is for the fuel pump.
burke is offline  
post #43 of 45 Old 03-26-2019, 11:52 AM
Squid
 
Join Date: Jul 2014
Location: caifornia
Posts: 39
oops nevermind, just saw issue has been resolved.
burke is offline  
post #44 of 45 Old 04-06-2019, 02:43 PM
Squid
 
Join Date: Mar 2019
Posts: 9
I have the same issue ive been dealing with. Ehat i noticed though is if i remove the fuse on the starter relay under the left side of seat and plug it back in it will start. But once i turn it off i would have to redo the process again to get it to start. Still scratching my head on this. Let me know it works.
Dtruong is offline  
post #45 of 45 Old 04-06-2019, 02:44 PM
Squid
 
Join Date: Mar 2019
Posts: 9
Quote:
Originally Posted by burke View Post
oops nevermind, just saw issue has been resolved.
Same lol
Dtruong is offline  
Reply

  ZX6R Forum > ZX6R Forum > The ZX6R

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ZX6R 09-12 Fuel Pump Malfunction? azlan_87 Mechanical and Technical 20 02-27-2019 05:17 AM
ZX6R Fuel Pump Wiring overheating [email protected] Mechanical and Technical 2 02-14-2019 02:37 AM
ZX6R 2010 wont start fi light on no fuel pump sound kawaz550gp Mechanical and Technical 2 11-15-2018 02:11 PM
Need fuel pump for an 08 zx6r asap Jamkawi1 Mechanical and Technical 0 08-24-2018 07:29 AM
2006 ZX6R Fuel Pump question jniedzi1 The ZX6R 1 05-19-2009 09:23 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome