Front brake issue - ZX6R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 02-19-2019, 08:02 PM Thread Starter
Squid
 
antcampo4's Avatar
 
Join Date: Feb 2019
Posts: 1
Front brake issue

I have a 2013 and the brakes on it have been fantastic (all stock with the exception of aftermarket brake lines). I daily the bike year round and one day mid day after riding it in the morning the front brake had no friction. No resistance at all and I can't figure out what it could be. There is no leakage and if I continuously pull the lever after a hand full of times the pads finally squeeze. If I try this while riding there is no response. What could it be?
antcampo4 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-19-2019, 08:06 PM
Post Master General
 
jd41's Avatar
 
Join Date: Apr 2015
Location: Monterey, California
Posts: 5,585

I Ride: 2014 Kawasaki ZX-6R, 2013 Kawasaki Ninja 300
Garage
Welcome. Take time to submit a new member intro.

Does this bike have ABS?

JL99
jd41 is offline  
post #3 of 6 Old 02-19-2019, 10:35 PM
Post Master General
 
RJ2112's Avatar
 
Join Date: Apr 2012
Location: Bowling Green, VA
Posts: 11,698

I Ride: '09 ZX6R
Air in the lines...... When was the fluid completely replaced with fresh? From a new, sealed container?

"Basic stuff fellas. Use your head for something other than to break your next fall."
RJ2112 is online now  
Sponsored Links
Advertisement
 
post #4 of 6 Old 02-19-2019, 10:55 PM
Post Master General
 
RJ2112's Avatar
 
Join Date: Apr 2012
Location: Bowling Green, VA
Posts: 11,698

I Ride: '09 ZX6R
Very first short term fix, is bleed the system at the MC, with the zerc fitting that is in place for this reason. Pump the brake until you have pressure, hold the pressure and slightly crack that fitting open.

Cover everything in rags first.....

"Basic stuff fellas. Use your head for something other than to break your next fall."
RJ2112 is online now  
post #5 of 6 Old 02-20-2019, 08:00 PM
Squid
 
leising's Avatar
 
Join Date: Jan 2019
Location: Buffalo, NY
Posts: 81

I Ride: 2001 zx6r and 2011 zx6r
Garage
Quote:
Originally Posted by antcampo4 View Post
I have a 2013 and the brakes on it have been fantastic (all stock with the exception of aftermarket brake lines). I daily the bike year round and one day mid day after riding it in the morning the front brake had no friction. No resistance at all and I can't figure out what it could be. There is no leakage and if I continuously pull the lever after a hand full of times the pads finally squeeze. If I try this while riding there is no response. What could it be?
Your Brake Lever should be firm, if it is not, there's definitely a leak (or air in lines so you need to bleed first), if you dumped it, the master cylinder could be leaking, the install OR the after market lines are not tight and become loose.

My next thought is is that I'd look at your brake pistons. If they are corroded then they well not slide enough to hit the pad! I had* soft ass brakes where I'd be 95% and the brake would finally get firm! (not fun for the track). So I replaced the calipers (in this case a set of hayabusa ones as they are larger). Due to the rusty pistons. I thought about replacing just those but the hayabusa brakes were cheaper! LOL!

My 3nd and final check would be fork seals, if they leak then they get on your brake rotors and you slide, that also happened to me.


So yeah Leaks from lines (got undone), Master cylinder is whopped, and then corroded pistons.

“If a man does not have sauce, then he is lost. But the same man can get lost in the sauce.”

Last edited by leising; 02-20-2019 at 08:04 PM.
leising is offline  
post #6 of 6 Old 02-21-2019, 11:10 AM
Squid
 
KawasakiBrad's Avatar
 
Join Date: Jan 2019
Location: Stony Plain (West of Edmonton, Alberta, Canada)
Posts: 34

I Ride: 08 ZX10R, 18 ZX6R, 17 Z125
+1 on bleed the brakes

You're probably low on fluid (top that up while bleeding)

How much of your pads are left? Anything less than 2mm (1/16") requires replacement.

Anything can kill you. Pick something fun.
kawasakibrad.com
Youtube Channel: https://www.youtube.com/channel/UCeP...s8E9AkGXTpYzeQ
KawasakiBrad is offline  
Reply

  ZX6R Forum > ZX6R Forum > The ZX6R

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Reduced braking power but pads are in good shape. Please help. polkavin Mechanical and Technical 11 10-30-2018 02:41 PM
Zx6r brake issue Petewins The ZX6R 1 07-15-2018 08:14 AM
(How To) Front Brake Pad Replacement ZoomSplat Guides 14 07-02-2009 06:31 AM
Rear brake Issue MuddFoot The ZX6R 2 06-29-2009 08:53 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome