Kawasaki Ninja ZX-6R Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all I'm new on hear. I bough a Zx6r b2h 2004 last year had problems with 3rd gear thought it was a slack chain from the sound but turned out 3rd gear was worn and shifter forks. I just finished rebuilding the gearbox I replaced the 3 shifter forks shifter drum 3rd and 4th gear and 5the gear. I got it all back in toke it for a test ride and still jumped out of 3rs.i been advised it could be gear change shifter shaft. But it seams all OK. I'm just stuck what els it can be as every thing has been changed and checked for ware. Any help would be appreciated
 

·
Registered
Joined
·
3,587 Posts
Did you buy brand new gears or used? If used, did you check the engagement dogs before install? If that's all good, check the shift rod and fork rods for straightness
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Did you buy brand new gears or used? If used, did you check the engagement dogs before install? If that's all good, check the shift rod and fork rods for straightness
Yes I got everything new from fowlers Bristol. New shifter forks new shifter drum new 3rd and 4th.and 5th gear. I just oderd a new gear change shifter shaft. I rang up m and p Swansea for advice. explained problems and every thing I changed. And he said next thing is the shaft that I just oderd. Then he said if I connect the rod from my gear changer to the engine and they ain't aligned the same than can cause the problems of not shifting tidy and not fully engaging the gears fully. I had a look and that's what it looked like. I didn't get them the same position and I adjusted the pedel on the engine and not on the adjustable rod. I haven't tried it yet as I have got the clutch out and the shaft out to replace. I checked if it was strait and looked good but I mite aswel put the new one in as every thing els is new
 
1 - 3 of 3 Posts
Top