Kawasaki Ninja ZX-6R Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Here's my setup: 08 ZX6R Nissin calipers, Vesrah RJL pads, Galfer SS lines, rebuilt 06 MC, Motul RBF600 fluid, ASV F3 levers.

Coming from a stock setup. The new brakes are absolutely incredible. Nice firm feel at the lever but, because they are so instant now, the switch for the taillight won't engage unless I get pretty hard on the brakes. Basically, I'm already slowing down way before the light comes on.

Anybody ever run into this? I had the new levers installed with the stock system with no problems. The stock MC, lines, and calipers were so squishy before the light was activated before any pressure was placed on the rotors. I'm guessing I could just grind a little material from the lever where it engages the switch, but I figured I'd ask here first before I went crazy.

Thanks for any insight guys!
 

·
Registered
Joined
·
475 Posts
I had the opposite problem, my light was constantly on but just the slightest nudge of the lever forward would turn the light off. For me, my fix was a few layers of electrical tape around the piece of the lever that interacts with the switch so that the lever would press the switch sooner (switch pressed = light off). Sounds like your MC is pushing your lever too much into the light switch but others should have better insight.


.
 

·
Registered
Joined
·
1,788 Posts
There's like a little nipple on the brake light switch. Sometimes it falls out of place when reinstalling that it won't engage properly. Had it happen to me. Loosened the screw, realigned the nipple, BOOM FIXED.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Ok cool. I'll loosen that screw and see if I can get it positioned better. I did have it off during the MC rebuild so is probably something I messed up. I appreciate the help!
 
1 - 4 of 4 Posts
Top