Kawasaki Ninja ZX-6R Forum banner
201 - 215 of 215 Posts

·
Registered
Joined
·
249 Posts
Does our mph have an influence on fuel mapping? I don't know the ecu code... Just a wild guess. Clogged high speed injectors?
 

·
Registered
Joined
·
80 Posts
Very odd your bike wont go over 125. mine is like yours 08 stock bike with just jumper mod an 125 is cake an im a pretty heavy rider (for now). i have seen well into the 130s with no issue but only tried it once an thats enough for me.
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #204 ·
I weigh 15 stone my friend is 18 stone same bike and hits 170 on the clock lol and no the mph reading doesn't effect mapping its all done by the atmosphere sensor, maff and o2's ....i think today i am going to go back to the secondary injectors as when i installed the new set it worked for that one test run which was very strange. Maybe bad connections under vibrations or as someone told me something in the fuel rails which keeps clogging them. Other problem is the dealer is arguing if i do anything myself he wont touch it lol cant win
 

·
Registered
Joined
·
106 Posts
Discussion Starter · #206 ·
Well in the past two weeks the bikes had a brand new front pipe, new ecu and lock set, new o2 sensors, cam timing and clearances checked and secondary valves in throttle bodies checked and none has fixed it. Lucky for me the work is all free and parts are free! The fuel is still running rich no matter what ecu....next thing they want to do is remove the alarm its a data tool s4 has anyone ever encountered a problem like this ever before on any bike?
 

·
Registered
Joined
·
5,086 Posts
Well in the past two weeks the bikes had a brand new front pipe, new ecu and lock set, new o2 sensors, cam timing and clearances checked and secondary valves in throttle bodies checked and none has fixed it. Lucky for me the work is all free and parts are free! The fuel is still running rich no matter what ecu....next thing they want to do is remove the alarm its a data tool s4 has anyone ever encountered a problem like this ever before on any bike?
What is a front pipe?
 

·
Registered
Joined
·
2,206 Posts

·
Registered
Joined
·
2,206 Posts
Fucking exhaust then. The part with the cat in
Haha yeah, headers. All good, mate. Figured you would've had some fancy wording anyways
 

·
Registered
Joined
·
15 Posts
Sounds like a clogged cat? Had one on a car that would run but had very little power took for ever to get to 70 mph but would! .... Replaced the dam Cat and ran like new!
 

·
Registered
Joined
·
9,136 Posts
^ much more likely to be the fuel pump or fuel pump sock......ie a fueling problem

motorcycle "cats" are nothing like car cats and rarely have a problem................ part of that is by design the other part is the environment and the lack of high mileage

MOTORCYCLES are not cars and are really nothing at all like cars!
 

·
Registered
2017 ZX6R KRT, 2014 SFV650, 2019 GTI MK7.5 Autobahn
Joined
·
72 Posts
For what its worth, I just got a ZX6R (second owner) and was maxing out the RPMs at around 135ish mph. Didnt feel right, so I took off the front sprocket cover and found the previous owner swapped it out for a 15t. I just threw on a 16t yesterday and the bike feels so much better all around. Its only 1t difference (same as 3t on rear) but its just what the bike needed to feel more useful and not as buzzy. Its how it came from the factory after all :)
 
  • Like
Reactions: Ninjaman08
201 - 215 of 215 Posts
Top