Kawasaki Ninja ZX-6R Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Okay I'm looking for fresh suggestions on how to fix my 03 ZX6R's idle/stalling issue. The idle still fluctuates and then eventually my bike will stall.

Here's a link to an old thread explaining the issue in more detail. There is also a video you can watch if you haven't seen it before: http://zx6r.com/mechanical-technical/21191-2003-zx6r-idle-issue-dies-video-update.html

This is a list of everything I have attempted and has not worked.

-Valve Clearance Adjustment
-Throttle body sync
-Ran at least 4 bottles of cleaners through the bike. (Sea Foam, Lucas, etc.)
-New spark plugs
-Cleaned the throttle body assembly
-Checked the timing
-Cleaned K&N air filter
-Checked for air leaks (couldn't locate one but it's still possible that there is one)
-Oil change
That's all I can remember right now. None of these have worked.

So I only have 2 other ideas that someone suggested, the throttle position sensor and the inlet air pressure sensor.

Does anyone else have any knowledge on what it could be?:O It would be much appreciated!?
 

·
Registered
Joined
·
1,166 Posts
definitely keeping my eye on this thread. any misfiring? what about when you ride it how does it act then? if you can ride it?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3 (Edited)
Nope, no misfiring. It runs great while i'm riding it. As long as i'm giving it gas it wont stall. I ride it everyday. Bought the bike with 11k miles on it and now it's at 17.5k miles. It's had this problem since the day I bought it ahaha.
 
1 - 3 of 3 Posts
Top