Kawasaki Ninja ZX-6R Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys I just picked up a 05 zx6r and have had nothing but problems. Ive owned previous streetbikes and to do all the work myself so I'm somewhat familiar with the diagnosis process. When I bought it kid told me it needed a stator so I had already ordered one from "Ricks" and easily did the install and it was getting late when I finished so I just made a few blocks and it worked fine. Next day I went to ride and it died a couple blocks from my house and wouldnt start. Jumped it off and limped home. Bought a brand new battery and a Rectifier to go ahead and just replace all 3 so it was out of the way. Rode maybe 30 mins and it died again. Same thing wouldnt start. Replaced the starter relay assembly and starter soleind as well. Now when I turn the key on nothing happens. Could my ignition switch have went out? I have no idea what else to do. Please help if ya can. Thank you in advance
 

·
Registered
Joined
·
214 Posts
I love how some peoples definition of a "Diagnostic Process" is to throw parts at it until it's fixed :geek:
Anyway onto your Issue, First up Starter Relay & Starter Selenid are the same component so we need to know what 2 new parts you actually threw on it
When you say nothing with the Key on I assume you mean no lights or sounds just a dead Duck ?
 

·
Registered
2005 Kawasaki 636
Joined
·
9 Posts
Check the wiring harness and look for grounding junction boxes to see if any of them are melted down.
 
1 - 3 of 3 Posts
Top