Kawasaki Ninja ZX-6R Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
235 Posts
Discussion Starter · #1 ·
I just installed my M4 GP slip-on and I cant ride due to snow in April but just starting it up I noticed a lot of white exhaust and a bad odor. Even though it is cold, it seemed like way too much exhaust, not to mention the bad smell. Is there something wrong?
 

·
Registered
Joined
·
7,344 Posts
Let it BURN! :devil:

Just a coating that's in there at first. It will go away.
 
  • Like
Reactions: mikemill

·
Registered
Joined
·
831 Posts
Damn it, Dave. I couldn't type that out fast enough. :lol:
 
  • Like
Reactions: Corvus

·
Registered
Joined
·
7,344 Posts
Damn it, Dave. I couldn't type that out fast enough. :lol:
Sometimes I'm just at the right place at the right time :p

Thanks guys. Can't wait for this damn second winter to pass. The bike sounds amazing now.
For sure! Just to let you know, the M4 has a stock baffle installed you can take out with some snap ring pliers (or needle nose if you're an idiot like me :p)

It's loud as hell though and doesn't sound as good IMO. Plus, I actually feel like I lost some bottom end.
 

·
Registered
Joined
·
235 Posts
Discussion Starter · #6 ·
For sure! Just to let you know, the M4 has a stock baffle installed you can take out with some snap ring pliers
Yeah, I actually got it with the stage 2 baffle. I live in kind of a quiet neighborhood and it sounds plenty loud to me. Once the weather clears up I'll be able to actually ride her and see how she really sounds.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top