Kawasaki Ninja ZX-6R Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Installed Yoshimura Fender Eliminator Kit (KRT 2019) --> Check Engine Light + No horn

I installed a Yoshimura Fender Eliminator on my 2018 Ninja400 last year with no problem. Feeling confident, I did the same for the 2019 zx6r last night thinking it was a complete success. The licenseplate light works, turn signals and break lights all are functional as expected (I didn't think to check horn). Job well done.

But then I woke up today and was about to ride out on the zx6 and noticed that my engine check light was on. I went on a ride around the block with the thought that maybe it would "figure it out" and the light would go away. It didn't. Then I tested the horn and no sound came. Did I royally screw up the bike by installing a Yoshimura Fender Eliminator? The only part that was electrical was cutting the stock license plate light and using the plastic soldering tube thing that Yosh provided. Did I royally screw up my motorcycle?! I'm only 90% freaking out.

The owner's manual says,
"The DFI system has malfunctioned. Have it checked by an authorized Kawasaki Dealership."
I intend to take the bike into my local Kawi dealership on Tuesday but was wondering if the bike is safe to ride to work. ... I think i'm just going to play it safe and Uber to work Monday and Tuesday.
What is everyone's insight? Any suggestions? Should i be freaking out?
 

·
Registered
Joined
·
26 Posts
Idk much but check the fuses if you haven’t. Had my taillight and horn quit on me after I swapped the taillight to an integrated (same fuse)
 

·
Registered
Joined
·
10 Posts
Doing the fender eliminator meant you at least loosened the servo motor. Did you disconnect the cable and maybe turn ignition like that? If so, that could be your check engine light. Horn has to just be a loose connection of blown fuse
 
1 - 5 of 5 Posts
Top