Kawasaki Ninja ZX-6R Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
hi new to all this as not had a bike for some years now , but bought a 98 g1 zx6.

but struggles to idle and if i put the light on the idle drops and then stalls , any ideas ?

also the front brake is very spongy , been told the discs my be warped ? i have put new pads in and had the pistons set , but still the braking is not smooth at all, it is like abs as it crabs .

apart from that i love it !!!!!! lol
 

·
Registered
Joined
·
4,609 Posts
Battery, maybe?
 

·
Registered
Joined
·
7,651 Posts
Spongy brakes most likely need to be bled
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
thanks for the advice , ok got new lines ordered ! gonna check the voltage on the battery !

which is the best way to bleed the brakes ? normal lever thing? or vacuum bleeder? or reverse?

ta
 

·
Registered
Joined
·
3,022 Posts
I do the lever thing. It works best for me. If your getting a pulsating feeling from the front brake lever then your rotors are warped. I know this because mine are doing it. Lol.
 

·
Registered
Joined
·
1,442 Posts
When braking, do you feel a studder at the lever or more just the handelbars?
Also when pulling the lever for braking, does it feel jerky? If so, then the seals in the master cylinder are going, rolling with the motion instead of scraping.

with the idle, after having used the choke and it's at steady rpm, did you play around with the idle adjusting screw? maybe you're idle is set too low. it should be around 1300-1500rpm.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
Hi , are the revs that high on idle ? Just seems alot.
And the lever feels fine and smooth but when I brakes can feel the ront end bounce when I brake , as if it grips then not then grips .

Driving me crazy !
 

·
Registered
Joined
·
4,283 Posts
Hi , are the revs that high on idle ? Just seems alot.
And the lever feels fine and smooth but when I brakes can feel the ront end bounce when I brake , as if it grips then not then grips .

Driving me crazy !
I doubt that the rotors are warped. It could be deposits on the rotors. Here are some things to consider: -Warped- Brake Disc and Other Myths
 

·
Registered
Joined
·
3,022 Posts
I rephrase my last statement. If the last person who put the tires on themselves and not at a shop and didn't take the rotors off at the time then the rotors could bent bent not warped. Just saying. I did it awhile back because I was rushing and afterwards you could feel it in the lever. Just saying. A cheap caliber tool would check that.
 

·
Registered
Joined
·
3,022 Posts
Hi , are the revs that high on idle ? Just seems alot.
And the lever feels fine and smooth but when I brakes can feel the ront end bounce when I brake , as if it grips then not then grips .

Driving me crazy !
Put the front of the bike on a stand. Get a ruler. Hold the end ruler against the side of the rotor and turn the wheel. If the rotor goes away from the rotor and closer again then the rotors are bent or warped. Easy diagnosis.
 

·
Registered
Joined
·
2,273 Posts
^^ one too many rotors in there haha but that's the easiest way ive heard of checking
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #14 ·
Ok got some sea foam , put some in the tank,which is the vacuum pipe I use ?
And the lights still cause the revs to drop , battery ok .

???
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #16 ·
update ! the left rotor is well bent , so got some new ones coming .

run some seafoam thru it , seems a little better .

light still cause revs to drop , but not as bad .
 

·
Registered
Joined
·
4,283 Posts
update ! the left rotor is well bent , so got some new ones coming .

run some seafoam thru it , seems a little better .

light still cause revs to drop , but not as bad .
Test the output of your charging system. If it is not putting out 14 - 15 volts at the battery terminals when it's running, then test the regulator/rectifier and the stator.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #19 · (Edited)
grrrrrrrr! now under 3 grand dont run on all cylinders . all this happened after i sprayed carb cleaner in, maybe need to take the carbs off and clean properly ?

any ideas ? as its really doing my head in .
 
1 - 20 of 22 Posts
Top