Kawasaki Ninja ZX-6R Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Yes I know the title doesn't make sense so allow me to explain. I'll be as thorough as I can.

The fuel pump only kicks in when I press down on the right side of the fuel tank or tilting the left side towards the right when the tank is mounted. When it's level or I push on the left side, it'll run like normal for a few seconds then it'll hesitate like it's not getting fuel and the fuel light starts flashing when there's fuel in it then dies. Runs fine if I take weight off the left.

This is when parked; when riding the last couple days it'll bog down momentarily then lurch whether I'm going straight or going through a turn.

Any thoughts on what could cause this? Anything that I could possibly miss?
 

·
Registered
Joined
·
14,133 Posts
You probably have a pinched wire, which is most likely grounding out, killing the pump. Since pressure on the tank left side seems to cause it to happen, that’s where you start looking.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
108159
Update: After a double check. The one of the wires at the connector fried. Linked the two fragments together and lo and behold. The pump primes. I’m about to clean it up and solder it back together.

Thanks RJ. Much love brotha
 

·
Registered
Joined
·
14,133 Posts
Sparks under a fuel tank are never a good idea.... glad you found it before you roasted your chestnuts
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
It always worries me when I see how close the positive terminal of my battery sits under my fuel tank.
IAs long as you keep the boot over it ( if it’s still there) you won’t have to worry about the twins getting blown off down there.
 

·
Registered
Joined
·
14,133 Posts
OP, you have found something that doesn't make a lot of sense -- I'm glad fixing the wire got the pump going..... what caused it to melt in the first place? If you don't figure that out you are likely to repeat this process.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
OP, you have found something that doesn't make a lot of sense -- I'm glad fixing the wire got the pump going..... what caused it to melt in the first place? If you don't figure that out you are likely to repeat this process.
A mystery beyond me sir. I’ve probably cooked something last time I was working on it. The possibilities are endless on that one. Getting to the rest of that wire was a bitch to get to and definitely don’t want to do it again. I’ll look further while it’s still apart.
 

·
Registered
Joined
·
13,313 Posts
IAs long as you keep the boot over it ( if it’s still there) you won’t have to worry about the twins getting blown off down there.
Haha. Yeah the boot is still over it but I squeezed in an extra piece of cardboard just to be safe.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
That’ll do along with the heat blanket on the tank’s underside which I hope you still have on there lol
 

·
Registered
Joined
·
10 Posts
Discussion Starter #12
Update: Checked all the wiring and there was a nick on one of the power wires on the pump’s connector. That may have caused the wire on the harness side to overheat and melt the insulation and fray nearly the whole stretch of copper since it may have touched the metal part of the unit.

I’ve reinforced the pump’s ground wire and isolated from the rest of the main harness so it’ll be easier to get to should it happen again (I hope not🙄). Will provide an update after a few rides.
 

·
Registered
Joined
·
220 Posts
If the wire is nicked...and a couple wire strands cut...and its a highish current wire...it could melt because when you have fewer wirestrands passing the same amount of current..they WILL HEAT UP
 

·
Registered
Joined
·
10 Posts
Discussion Starter #14
If the wire is nicked...and a couple wire strands cut...and its a highish current wire...it could melt because when you have fewer wirestrands passing the same amount of current..they WILL HEAT UP
I figured that out the hard way brotha. I was lucky enough to get her ass home before it completely went kaput.
 
1 - 14 of 14 Posts
Top