Kawasaki Ninja ZX-6R Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
150 Posts
Discussion Starter #1 (Edited)
I know its though to diagnose on the net but just chiming in to see if anyone has had experience with this particular code? Service manual reads: exhaust butterfly valve actuator malfunction (exhaust servo) wiring open or short?

Run down...

I've had a full exhaust for 2000 miles with no issues, 200 miles ago the code appeared. Cables pulled, servo in place, still winds back and forth when ignition is turned on which leads me to believe it's functional. Also disconnected battery to see if code would clear but still on. Not ready to flash ecu yet so any help in the mean time is appreciated.
 

·
Registered
Joined
·
3,110 Posts
Servo buddy time! The gears in the servo motor might be wearing out and/or aren't getting the right resistance which would cause it to throw the code. I don't have a servo buddy and am running a slip-on with cables removed and have yet to encounter this. When it does happen, I'll be getting the servo buddy.
 

·
Registered
Joined
·
150 Posts
Discussion Starter #3
Servo buddy time! The gears in the servo motor might be wearing out and/or aren't getting the right resistance which would cause it to throw the code. I don't have a servo buddy and am running a slip-on with cables removed and have yet to encounter this. When it does happen, I'll be getting the servo buddy.
That's odd, I've had the servo on my 10r cable-less for years w no issues. I'd reflash before a SB but just wanted to see how many peeps are encountering the same problem.
 

·
Registered
Joined
·
3,110 Posts
That's odd, I've had the servo on my 10r cable-less for years w no issues. I'd reflash before a SB but just wanted to see how many peeps are encountering the same problem.
I'd hope you aren't reflashing only to remove the FI light...
 

·
Registered
Joined
·
61 Posts
I am cable-less with servo in place as well and so far no FI light, although I do have the extremely aggravating warm start issue. We'll see if the FI comes on or not.
 

·
Registered
Joined
·
61 Posts

·
Registered
Joined
·
150 Posts
Discussion Starter #8
I'd hope you aren't reflashing only to remove the FI light...
Lol no man.... I would have done it already but $ is tight after clip-on, rear sets, tires, race glass, complete bazzaz set-up and suspension in the works :headbang:
 
1 - 10 of 10 Posts
Top