Kawasaki Ninja ZX-6R Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Any one have a idea how long it will take to remove and replace the engine in my 2013 636 or have any useful tips and hints to get the job done efficiently and quickly
 

·
Registered
Joined
·
1,874 Posts
Any one have a idea how long it will take to remove and replace the engine in my 2013 636 or have any useful tips and hints to get the job done efficiently and quickly


Give Rivers a ring... But, be prepared. Take pictures. Do you intend to replace a '13 with another '13? Or are you gonna use a '14-'18. I know they are essentially the same, but there will be year to year running production changes.

Have you ever actually removed a engine from its frame? It's not overly difficult. But do take complete notes - snap some photos along the way. Use zip-lock bags to corral like bits & bobs; label them completely.

It is a job one can perform by them self - with the help of a automotive floor jack, though a helper is a great benefit :coocoo. Reread the service manual again. And maybe again. Make sure you have all proper tools to perform the job. Ask Rivers for specific dos/don't dos. What of special notes of interest that are specific to era of engine. If you haven't yet ordered all parts that you'll need, i.e., gaskets, seals, etc., do so now. Every things goes back together easier if you do the install recently after the O.E.M. removal. Little things stay fresher in your brain.

Good luck.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
It is a 2013 engine being replaced by a 2014 engine but the engine numbers start the same 636EE so I think essentially it's the same model of engine just a later registration bike 2013 model registered in 2014.

I have done a engine swap before on smaller single cylinder bikes but nothing this new or complicated. I have read the manual and only need one specialist tool which I purchased.
I will probably be doing the job solo. Should I need any new gaskets?
The new engine only has 3k on it
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
new engine is fitted now but it wont tick over and is throwing up fault code 62 check engine light is on as is the traction control light, all power mode lights flashing as is the 123 traction control. looked up the fault code and its the subthrottle valve actuator. when i took off the air box to check the valve opens when i turn on the key but when it comes back to the closed position the valve jutters like its hits the stop. if anyone has any suggestions that could help or a way to clear the code
 
1 - 7 of 7 Posts
Top