Kawasaki Ninja ZX-6R Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Hey everybody, run into an issue. After riding for about an hour, my 05 zx6r will start hesitating hard, almost as if im tapping the front brake. Then it will sputter and stall out, to the point where it will either not even start or will idle but stall as soon as you touch the throttle. Is my ECU cooked?
 

·
Registered
Joined
·
247 Posts
ECU is the last item to suspect and I often wonder why it's some Folks first thought, Odd.
How many Miles ?
Off the Bat my first thought is bad Gas, Did you fill up and start experiencing this shortly after ?
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
Not bad gas. I did some googling and there are a few people with same bike, same issue. Its happens after about an hour of riding. Today as well as the first time it happened, i was on the highway cruising at about 88. Temp on the gauge was about 188 when it starts chopping out. The bike has about 23000 miles. Fresh plugs as of late last year along with the valves adjusted by a kawi dealer shop.
 

·
Registered
Joined
·
247 Posts
Fuel pumps are a favourite with this Model, Have you a way of measuring the Fuel Pressure and Delivery ?
 

·
Registered
Joined
·
14,580 Posts
The ECU in the ‘05 has a history of breaking down and failing due to overheating.
 

·
Registered
Joined
·
8,194 Posts
I would not jump to the ecu either...... and while sure out of the tens of thousands of these bikes made and sold a handful had ecu overheating issues (less than 1% I am sure)

I would be more suspect of the tank not venting correctly or the fuel pump sceen being restricted or the fuel pump itself

all eqasily checked and remedied long before you go buy a new ecu (as buying a used one you are just as likely to get a bad one as saying yours is bad) and new ones are super expensive!

Do the proper diagnostics!!!!!!!
 
  • Like
Reactions: KevA

·
Registered
Joined
·
33 Posts
Discussion Starter · #8 ·
Alright so I did the test where i caught the amount of fuel coming out when the pumped primed. Pushed out just under 100ml when I turned the key on. Any suggestions from here?
 

·
Registered
Joined
·
247 Posts
Standard for the 3 second prime is 67ml so the delivery is ok but still need to know the pressure.
I suspect you don't have a Fuel Pressure Tester ?
 

·
Registered
Joined
·
14,580 Posts
Stupid question, could a vortex fuel cap cause issues?
The classic symptom of a kinked vent line is when your bike stalls to open the gas cap. If you hear air rush in, the vents are clogged and the pump has created a partial vacuum in the tank, which it cannot pull any more fuel from.
 

·
Registered
Joined
·
247 Posts
Never had an issue with one and I've come across loads of them on various Bikes.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #14 ·
Ok, found a thing. The tank vent line was pinched between the belly fairing and the lowering link. Could a pinched vent line cause power loss and stalling?
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #16 ·
Ok, so found an issue. My power commander 3 doesnt power up at all. When i put a 9v battery to it, it powers on like it should. Could this cause my issues?
 

·
Registered
Joined
·
14,580 Posts
Ok, so found an issue. My power commander 3 doesnt power up at all. When i put a 9v battery to it, it powers on like it should. Could this cause my issues?
Unplug the pc3 entirely and see how the bike runs without it…..
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #18 ·
Alright, so i solved the pc3 dilemma. Turns out it was all unplugged except the ground. The shop i went to to have the valves and plugs done must unhooked everything. I havent gone on a test ride yet. I dont suppose an untuned bike with mods could cause serious issues right?
 
1 - 19 of 19 Posts
Top