Kawasaki Ninja ZX-6R Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello,

So I recently bought a 2015 zx6r fully stock. Equipped it with a decat pipe and akrapovic slip on but left the catalytic converters inside the headers. To compliment all of that I installed servo buddy and a o2 sensor eliminator, so that bike wouldn't run lean ( probably need a PC5 nad a tune too?).
So anyways, the problem is, that when I'm at cruising speed at like 6-7k RPM in 5th or 6th gear and ride like that for a while my Engine check light comes on and I noticed that's there's way more backfiring and popping noises after that. When I stop, turn the engine off and start it again the check light is gone. Imo bike starts running too rich at low rpm's and that causes all the popping and backfiring. Any suggestions?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Cant u pull the code?
I tried doing so but I doesn't seem to work as it is described in user manual. Turn ignition on, go to odometer, hold MODE button for 2 seconds or more and nothing happens. Maybe it's done differently on ABS model?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Or maybe it just doesn't show, because when I turn off the ignition and turn it back on the engine check light is gone.
 

·
Registered
Joined
·
13,310 Posts
Im not too familiar with the 2015 models. Is the Check engine light separate from the FI light on those? I know on the newest models it is separate.
 

·
Registered
Joined
·
13,310 Posts
From another post:

To read the check engine code: Put it on odometer reading and press A mode button and hold it for a while.
 
1 - 9 of 9 Posts
Top