Kawasaki Ninja ZX-6R Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
The bike is an 07 zx6r. Bike has run last season beautifully. Sat for about 8 months with fuel in it. I emptied out the gas and filled it with new gas. Fuel pump wasn't building pressure and was clearly shot so I replaced that along with a new fuel filter. When I go to fire it up, it cranks great but then just takes a bit of effort for it to fire up. When it's started, it idles poorly and will stall if I don't give it throttle to stay at above 2k RPM. As the title states, the throttle is very delayed (about half to a full second delay). The bike won't rev past around 6-7k RPM, but if I want it revving that high, I have to ease the bike there and if there are any sudden throttle changes and it won't rev past 4k.
Anyone have any ideas?
 

·
Registered
Joined
·
13,065 Posts
Are your injectors spraying normally?
Is your intake clean?
Spark plugs good?
Make sure your butterfly valve in the exhaust isnt stuck closed (if u still have original muffler)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I'll try checking the injectors and take them to a shop to professionally clean if they're clogged
Intake is clean
The plugs have been replaced right before storage (8 months ago). Could they go bad just from sitting?
I have an aftermarket exhaust
 

·
Registered
Joined
·
133 Posts
Have you done valve maintenance recently? Had very similar issues when my camshafts were off.
Could also be worth checking vacuum lines.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
As far as I know, there was a valve adjustment on the bike shortly before I got it. Only put about 50 miles on it since I got it (7050 miles total). Ran fine months ago before storage.
Just checked the vacuum lines and there seems to be no leaks.
 
1 - 7 of 7 Posts
Top