Kawasaki Ninja ZX-6R Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello everyone,

I changed the stock front and rear turn signals on my 95 zx6r F model to LEDs. They blinked way to fast and after reading forums, I realized I needed to replace the relay with a new electronic LED flasher relay. Did that.

Now they blink at the right rate, but all the blinkers blink like a hazard lights would. The backs are about the same luminosity, but the fronts are bias to the direction of the turn signal switch. The turn signal indicator lamp on the dash is not working either. The indicator lamp is an incandescent and appears not to have enough voltage to light up.

I have read about people wiring up diodes on both sides of the indicator lamp. I have also read about people just taking the bulb out and completing the circuit (but I want that light on the dash to work)

Can I find an LED indicator bulb and that will work? Anyone wired those diodes in with the stock indicator and had success? Thanks in advance
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
Correction: Everythings works fine when I remove the indicator bulb from the dash and DO NOT complete the circuit. I really want the indicator bulb working though
 

·
Registered
Joined
·
92 Posts
i want to say that i am going through this EXACT same problem right now. i did the diode mod exactly how it states in that 250 write up, and then none of my blinkers worked at all. it creates a dead short in the circuit. so im still at a loss with this issue. OP, let me know if you figure it out!!!
 
1 - 5 of 5 Posts
Top