Kawasaki Ninja ZX-6R Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I've got a 2016 ZX6 with 11000 miles on it. It has a noticeable top end noise (rattle, tapping maybe) on the right hand side where the cam tensioner and oil cooler is. It gets better when the engine is warm. It became much more noticeable when the weather cooled down here. I do believe it is slowly getting louder/worse. Is there a way to "reset" the OEM cam tensioner? Or would I need to replace it? I'm thinking of just removing it and reinstalling it with a new o-ring.

I've already checked for loose headers, exhaust leaks, loose radiator, etc. It rides the same as when it had 1k miles except for more pops and crackles since the weather cooled down. I'm hoping I don't need to do the valves early.
 

·
Registered
Joined
·
3,242 Posts
I've got a 2016 ZX6 with 11000 miles on it. It has a noticeable top end noise (rattle, tapping maybe) on the right hand side where the cam tensioner and oil cooler is. It gets better when the engine is warm. It became much more noticeable when the weather cooled down here. I do believe it is slowly getting louder/worse. Is there a way to "reset" the OEM cam tensioner? Or would I need to replace it? I'm thinking of just removing it and reinstalling it with a new o-ring.

I've already checked for loose headers, exhaust leaks, loose radiator, etc. It rides the same as when it had 1k miles except for more pops and crackles since the weather cooled down. I'm hoping I don't need to do the valves early.
The service manual will lay out all the steps for removal and re-install to do a CCT reset. May as well give it a try.
 
1 - 4 of 4 Posts
Top