Kawasaki Ninja ZX-6R Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone I am a new rider and have a completely bone stock 2007 zx6r other than a scorpion stealth slip on with 9k miles. Bike runs great, no gas leak seen or smelled but I am only getting 40 miles on a full tank before gas light comes on. I am buying the fuel with the highest octane (the most expensive one). Please help me out if you have a had a similar issue, thank you.
 

·
Registered
Joined
·
41 Posts
Something seriously wrong there


I take it it is then needing the right amount of ltrs to fill it back up?


Just incase it's a faulty fuel level switch
 

·
Registered
Joined
·
167 Posts
when you stop to fill up, how many gallons do you fill up? like jackstrath stated, it might just be the sensor.
Welcome to the forum btw!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
when you stop to fill up, how many gallons do you fill up? like jackstrath stated, it might just be the sensor.
Welcome to the forum btw!
Thanks man yeah it's a great forum, but yeah I have to fill the bike up with some gallons to get a full tank again
 

·
Registered
Joined
·
41 Posts
That's mental , something is seriously up, how does the bike ride ? When you shut off the throttle does the bike keep going ?

At that sorta rate you would expect to see flames out the back once the exhaust got up to temp lol
 

·
Registered
Joined
·
69 Posts
Are you completely sure there is no leaks or signs of gas anywhere around the fuel lines or gas tank? You can't be running this rich either. The gas would completely flood the cylinders. Maybe someone is stealing your gas?


At that sorta rate you would expect to see flames out the back once the exhaust got up to temp lol
Bro, imagine? A flamethrower out the exhaust? Haha
 
1 - 8 of 8 Posts
Top