Kawasaki Ninja ZX-6R Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
As the title says i have a 03 zx6rr. My problem is is that my buddy rode it like 4 days ago and ran it out of gas. Put a full tank of gas in it, ran like normal, and yesterday it lost all power and wouldnt crank back up! I put a battery charger on it overnight, cranked it up and it ran for 10 seconds with the charger still on the battery before it cut off once again! Any ideas on what it could be? Thanks for all the help i can get!
 

·
Registered
Joined
·
441 Posts
My buddy did the same thing to his bike (05 636). It destroyed his fuel pump, so we replaced it and it was good to go.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
So you think that would be the first step? Do you know approximently how much im going to spend getting that done?
 

·
Registered
Joined
·
441 Posts
Do it yourself man. A used one goes around $85 on ebay. Just lift up the tank, drain the gas out, the rest is a simple swapping of the parts. (if that is the issue)
 

·
Registered
Joined
·
1,203 Posts
you can find cheaper on ebay that $85. I've bought them for as low as $30 delivered. The 03 is carbs? If so, it would have the lower psi fuel pump than a FI system. You might want to disconnect the fuel line going into the manifold, put it in a container & turn on the key ON to see if it pumps the right amount of fuel in a certain amount of time (should be in manual). Also might want to check static & running psi with a gauge (rented free from auto parts house).
 

·
Registered
Joined
·
1,307 Posts
03 is the same as 04 , fuel injected both r and rr, I would say 99% its your pump don't mess with the cheap knock offs I did and I have priming issues just hit partzilla for one for about $250
 

·
Registered
Joined
·
441 Posts
you can find cheaper on ebay that $85. I've bought them for as low as $30 delivered. The 03 is carbs? If so, it would have the lower psi fuel pump than a FI system. You might want to disconnect the fuel line going into the manifold, put it in a container & turn on the key ON to see if it pumps the right amount of fuel in a certain amount of time (should be in manual). Also might want to check static & running psi with a gauge (rented free from auto parts house).
Oh damn, didn't realize how cheap they are for the 03-04 lol
 

·
Registered
Joined
·
1,203 Posts
03 is the same as 04 , fuel injected both r and rr, I would say 99% its your pump don't mess with the cheap knock offs I did and I have priming issues just hit partzilla for one for about $250
oh yeah, me furgits at times.....

I have used quite a few fule pumps from A-Zone as well & never had an issue with them. I believe one from a mid 90's Accord will drop right in.
 

·
Registered
Joined
·
6 Posts
I have a fuel pump I picked up for my 03 ZX6 rr cheep off a running bike when I was chasing issues, get the whole thing not just the "male" end what every you do.
 

·
Registered
Joined
·
89 Posts
I don't know... sounds weird that it ran perfect once you filled it up and now it wont run at all. does the pump have the same priming sound when you turn on the start switch as it used to or what? At first when i read it i was thinking it could have been vapor lock from running it completely dry but i don't know if that happens with motorcycles seeing as the tank is directly above the injectors.
 
1 - 14 of 14 Posts
Top