Kawasaki Ninja ZX-6R Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi guys, as a newbie to this forum this is my 1 st post. I ride an '09 zx6, have owned it for two years now, a superb bike in my opinion!!
Here's the thing though I bought it with a Scorpion carbon end can which was dealer fitted. Just over the last month or so, the FI warning light has been coming on intermittently, I've looked up the fault code, guess what? The dreaded exhaust servo problem!!
This is the reason I joined this forum, to hopefully find a cure.
Anyhow, I've looked at the servo buddy, sounds good, but a bit pricey, so, thought I'd try re setting it first by disconnecting it as per the workshop manual, this worked for a short while, but soon reared it's ugly head again,
Anyway also looked at the route of making my own buddy, but don't trust my skills with a soldering iron too much. So I decided on another route, my manual states that you should disconnect the servo with the ignition off, then re- connect it with the double plug first, then connect the triple one, switch it back on, and ther you go, as I said previously, it works for about a day or so.
Now, I decided to do exactly the same procedure, only this time I switched the ignition on after connecting both plugs in sequence. Guess what no more light and it hasn't come back since.
Thought you'd like to know before you shell out on a servo buddy or make your own, at least you won't have to butcher the loom off of the servo. Give it a whirl, it can't do any harm!!!!
 

·
Registered
Joined
·
7,651 Posts
09-ZX6R makes and sells servo buddies for cheap. Send him a pm
 

·
Registered
Joined
·
1,259 Posts
$35 for my S.M.E. shipped...anywhere in the USA...ships within 24hrs of payment reciept. not including weekends and holidays....
 
1 - 4 of 4 Posts
Top