Kawasaki Ninja ZX-6R Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello i am new here, and forums in general.. i usually just look up another discussion about the same problem but ive tried all the remedys on other threads..

I have an 04 zx6 with pc that is shutting off suddenly while riding.

Its immediate. No bog down. No fi or oil lights until its already dead then it just shows oil light as always.
it just suddenly stops firing, i coast to the side of the freeway put it in neutral and press the start button and continue on my way. It happens usually twice or more on my 15 minute ride to work.

Heres the confusion.
I disabled the kickstand switch when i bought the bike.
At that time i also gutted the tip over sensor because it always shut the bike off in a wheelie.
My gas tank does not whistle or anything like a symptom of a clogged breather, ( although i am going to leave my gas cap open tomarow while i ride just to make sure)
Last time it died i started it back up and shook the living hell out of everything on the bike, i checked the battery terminals, wiggled the ignition, kill switch, all wiring i could get my hands on. Still nothing.

The bike has a pc3
And thats about it,
The only thing thats really in need of replacement is the oil filter wich im hoping it is just sensing low pressure or something and killing the bike, but i would think it would throw an oil light.
Either way it will be replaced tomarow too.
Thats all i got i have no other ideas at this point.
If anyone has any ideas i would highly appreciate it
 

·
Registered
Joined
·
4,877 Posts
^^this^^

Pull the PC3 and see if that's what's causing the issue first (because it's quite likely it is). If that's not the problem, it sounds to me like you have a problem with the ECU itself.

The oil filter is definitely not your problem.
 
  • Like
Reactions: Kawistuntz and Indy

·
Registered
Joined
·
3 Posts
Discussion Starter #6
How did you disable the kickstand switch and tipover switch?
Its been a while but on the kickstand i think i just cut the wires and tied them together.

On the tip over sensor on the inside is a little bar and weight, i just removed them and put it back together
 

·
Registered
Joined
·
114 Posts
Its been a while but on the kickstand i think i just cut the wires and tied them together.

On the tip over sensor on the inside is a little bar and weight, i just removed them and put it back together
Did you solder the wires together? Maybe make sure they're not coming apart.

I agree with eliminating the power commander, though, as a debugging step.
 
1 - 8 of 8 Posts
Top