FI light came on after washing my bike - ZX6R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 03-29-2012, 06:59 PM Thread Starter
Squid
 
Join Date: Mar 2012
Location: FL
Posts: 29
FI light came on after washing my bike

I wanted to start a thread to maybe help some others out if they run into the same problem as I did. I have a 2006 ZX6R with 5800 miles. I washed my bike the other week just like I usually do with a hose and soapy water. Ive never had a problem with this before and figured it was ok to ride in the rain so a little water wouldnt hurt it. Big mistake on my part. After I washed it, I took it for a quick spin around the block to get any extra water off it and noticed it was running a little strange, almost hesitant to rev but I didnt think much of it as I was only doing low speeds and I didnt have my helmet on so I didnt take much notice to the different sounds as I thought it was just because I didnt have my helmet on. I parked the bike and called it a night. The next morning I get ready to go to work and jump on the bike and after a few minutes of riding, the FI light comes on and the bike literally just starts running like complete crap. I have a 45 minute ride to work and was only about half way. I take it real easy the rest of the way and make it to work. I figure maybe some water got somewhere it wasn't supposed to and hope that sitting in the sun all day while I'm at work will dry it out. After work, I get back on the bike and the light is still on and its still running poorly. Also, the normal sounds that come from under the tank are replaced by a terrible screaching and grinding sound like the throttle bodies are stuck and struggling to open. When I get home, I whip out the manual and check the codes from the FI light. I get a 32 and a 62, both of which have to do with the subthrottle activator and sensor. I did a little searching online and on several forums and found a few others who have experienced this after washing their bike but none really explained what the problem ended up being or how they fixed it. So I set to work taking the bike apart and following the service manual checking anything I could that didnt require the special kawasaki tools. Everything was checking out fine but there were several areas I couldn't test without the special tools. I called a few shops around town and found one that was very knowledgeable and steered me towards the TPS. He had seen this same thing happen before. He told me to replace the throttle body assembly. The throttle bodies contain several sensors, including the subthrottle sensor and the throttle positioning sensor. Its easier to replace the throttle body assembly than it is to replace these sensors. So, I get online and order a set of throttle bodies off ebay. Today, they arrived and I bolted them right up. I cross my fingers and turn the key...no fi light! No more terrible sound. Everything seems ok. I havent completely finished putting the bike back together because I am getting the tank painted to match my new fairings so I have to wait for that before I can fire it back up but it seems to be fixed. So lesson learned, be careful when washing your bike with a hose. And if you get a 32 or 62, the throttle body assembly is probably the prime suspect to replace. Let me know if any of you have had an experience like this.
mrmcbizzie is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 03-29-2012, 07:17 PM
Pro Racer
 
ZX6Ray's Avatar
 
Join Date: Mar 2012
Location: The Armpit of the USA
Posts: 725

I Ride: 2009 ZX6R Monster Edition
Honestly I don't know why a lot of people spray the shit out of thier bikes or use those car wash pressure washers... Bad choice. You can definetly short something out that way if water creeps its way into a connector or electronic device.

All you should have to do is put a little orange citrus in the dirty crevices on the bottom of the bike and only use a garden house to spray the wheels and side fairings slightly. Use some soap on the wheels and side fairings and don't start the bike until it dries a bit or use a leaf blower. I NEVER spray direct pressure by the instrument cluster or where on the sides of the tank/seat where these sensitive electronics are. I often just wipe the tank and cowl with plexus.

I'm not sure but I don't think you had to replace the whole throttle body assembly for a few sensors but if it was cost efficient then more power to you. Glad you brought this situation to all those out there who think pressure washing or spraying the crap out of everything on your bike it is a good idea

Good Job fixing the problem!

Throttle up, knee down and pray!
My monster decals make 20 ft-lbs of static pressure transducer horsepower to the vtec controller boost gauge!
Quote:
Originally Posted by MistressOfMayhem View Post
Tell me, oh wise one of the Monster Regime, instead of putting NOS in your gas tank, is your bike powered by Monster?
Quote:
Originally Posted by Starscream View Post
I'll stick to KNOWING my 09 makes 124.5whp with just a filter, full LV system and a tune.
Quote:
Originally Posted by renzovc16 View Post
Waz up hommies i just got my led glow lights in da mail from ebay !
ZX6Ray is offline  
post #3 of 11 Old 04-30-2012, 06:30 AM
Team Green
 
636rob87's Avatar
 
Join Date: Jan 2012
Location: fl
Posts: 113
I have a 2006 zx6r, it rained like hell this weekend. I went to ride to work this morning after waiting for the rain to calm down a little and noticed the Fl light on. I only noticed it when I was waiting at a stop light, then it turned off once I started riding again (Prob like 30 seconds later). I didn't experience anything strange with the bike although it was raining and I was keeping the rpm's way down.

Hopefully I won't have the same problem as you did

Last edited by 636rob87; 04-30-2012 at 07:38 AM.
636rob87 is offline  
Sponsored Links
Advertisement
 
post #4 of 11 Old 04-30-2012, 07:03 AM
World Superbike Racer
 
Fletch's Avatar
 
Join Date: Oct 2011
Location: North East UK
Posts: 1,282

I Ride: 2003 ZX6R
I hate washing my bike it just feels wrong?

You have to be carefull not to get certain parts wet, or is this just me ? ? ?

Black double bubble screen, Pro Grips black and green, Shorty levers, Moto gp carbon stubby can "Loud As Hell" Aluminium pegs with ZXR engraved in them, R&G Tail tidy, Green wheel rim tape, Bright white LED side lights, Decals removed, Rear seat cowel, Carbon petrol cap cover, Front and rear tinted lights, ZX6R Monster tank pad, Zip tie mod, Clean air mod
Fletch is offline  
post #5 of 11 Old 04-30-2012, 08:26 AM
Squid
 
Join Date: Apr 2012
Location: Powell, Wy
Posts: 23

I Ride: 07 zx6r ninja
My bike has the same fI displaying on the meter. I'm not exactly sure when it come up but how do I figure wat code it is.. ?
My oil icon on the meter is being displayed too, any ideas.. Manual says something with oil pressure. Can this be fixed myself
mendozaKikii is offline  
post #6 of 11 Old 04-30-2012, 11:45 AM
World Superbike Champion
 
d1andonlyant's Avatar
 
Join Date: Apr 2011
Location: Nr Cambridge, England
Posts: 2,273

I Ride: 04' ZX636
heres how to pull your codes and what they mean

https://zx6r.com/mechanical-technical...-fi-codes.html

i normally get my bike done at the carwash down the road and they use pressure washers. i never really thought anything of it. so is it worth putting a bag over the dials and over the battery and fusebox under the main seat too?

04' ZX636
Ram Air Mod - Kleen Air Mod
Short Stacks Mod - MWR Filter
MHP Full Exhaust - PCIII W/Custom Map
SP Quickshifter - 2012 Shock
SS braided Lines - GPR V4 Damper
__________________
I ride my bike like I ride my girlfriend - hard and fast until the rubber blisters or she runs out of juice....
d1andonlyant is offline  
post #7 of 11 Old 04-30-2012, 11:53 AM
Team Green
 
Join Date: Nov 2011
Location: Arnaudville, LA
Posts: 177

I Ride: 2008 Kawaski ZX6R
I pressure wash my 08 all the time. And it runs great no problems at all
FSTZX6R is offline  
post #8 of 11 Old 04-30-2012, 01:47 PM
bod
World Superbike Racer
 
bod's Avatar
 
Join Date: Oct 2007
Location: ROTHERHAM,UK
Posts: 1,687

I Ride: kawasaki zx636r c6f
I only lightly spray bike with hose,and wash with bucket and sponge, but never put hose on tank area or instrument gauge or rear seat area as power commander etc are in this area...always start the bike afterwards and let her warm up as to dry her out a little...

KAWI ZX6R 06 636
CARBON FIBRE AIRBOX TANK COVER,CARBON FIBRE SWINGARM COVERS,CARBON FIBRE HUGGER,CARBON FIBRE MUDGUARD,CARBON FIBRE CHAIN GUARD,CARBON FIBRE ENGINE COVERS,CARBON FIBRE DASH PANELS,CARBON FIBRE FRAME PROTECTORS,CARBON FIBRE DECALS,BREMBO MASTER,ZZR1400 FRONT CALIPERS,ZX6R 2014 310MM DISCS,HEL BRAKE LINES,EBC SINTERED PADS,PAZZO SHORTY LEVERS,GALFER WAVY REAR DISC,POWERCOMMANDER3 WITH CUSTOM MAP,K&N AIR FILTER,IRIDIUM PLUGS,DE-CAT,ARATA RACE CAN,RAM AIR MOD,08 REAR SHOCK,2012 MIRRORS,SMOKED INDICATORS,HOT BODIES SMOKED SCREEN,GILLES REARSETS,POWERBRONZE GREEN CRASH BUNGS, BIKE REPAINTED KAWI GREEN WITH CARBON FIBRE DECALS AIRBRUSHED..
bod is offline  
post #9 of 11 Old 04-30-2012, 04:15 PM
Squid
 
Join Date: Apr 2012
Location: Powell, Wy
Posts: 23

I Ride: 07 zx6r ninja
Ok. So I looked at how it's done to get the codes. I took notes and everything, came to look at my bike and it's differENT. (07 ZX6r) anyway to get around this..
mendozaKikii is offline  
post #10 of 11 Old 04-30-2012, 04:28 PM
World Superbike Champion
 
d1andonlyant's Avatar
 
Join Date: Apr 2011
Location: Nr Cambridge, England
Posts: 2,273

I Ride: 04' ZX636
i thought it was the same but am far from sure. Heres a link to the manual, should say in there

http://www.mediafire.com/file/452kqh...s/ZX600P8F.pdf

04' ZX636
Ram Air Mod - Kleen Air Mod
Short Stacks Mod - MWR Filter
MHP Full Exhaust - PCIII W/Custom Map
SP Quickshifter - 2012 Shock
SS braided Lines - GPR V4 Damper
__________________
I ride my bike like I ride my girlfriend - hard and fast until the rubber blisters or she runs out of juice....
d1andonlyant is offline  
post #11 of 11 Old 04-30-2012, 04:43 PM
Squid
 
Join Date: Apr 2012
Location: Powell, Wy
Posts: 23

I Ride: 07 zx6r ninja
alright. thank you
mendozaKikii is offline  
Reply

  ZX6R Forum > ZX6R Forum > Mechanical and Technical

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
My bike downed a newer GSXR !!! lol ZX6EDGE Racing 12 06-24-2014 05:38 PM
Which bike would make the best track bike Gav179 Motorcycle Talk 14 02-22-2012 03:23 PM
Tail Light electrical problems 2201436 Mechanical and Technical 11 12-17-2011 07:53 PM
Bike does not start, help identify the issue. Ambient The ZX6R 10 03-23-2009 08:45 AM
New to the forum and new to this bike raddiver The ZX6R 23 01-10-2009 06:58 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome