charging problems - ZX6R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 07-02-2011, 02:30 AM Thread Starter
Squid
 
Join Date: Jul 2011
Location: crawley, united kingdom
Posts: 3

I Ride: zx6rg2 1999
charging problems

help! i have a 1999 g2 model and the battery keeps discharging and the battery will not stay charged after recharging. any ideas what the cause is? poss regulator/rectifier or starter relay or possibly the alternator. i have been told by a bike dealer that it is more likely to be the regulator/rectifier
kwakzxr is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 07-02-2011, 02:31 AM
Post Master General
 
arron's Avatar
 
Join Date: Jul 2007
Location: melbourne
Posts: 11,637

I Ride: 1998 zx6r, 1999 sv650
is it a new or old battery? welcome to the joint




tinted screen, hel lines,intergrated tail light, rearset adjusters, K&N air filter, +4 advancer, -1 front, pazzo knock offs, ape cct, zip tie mod,07 shock + rear disk, 08 swingarm, vernhil rear line, 636 exhaust with dan moto cf can, Kleen air mod..

still lovin forever!
arron is offline  
post #3 of 6 Old 07-02-2011, 02:36 AM Thread Starter
Squid
 
Join Date: Jul 2011
Location: crawley, united kingdom
Posts: 3

I Ride: zx6rg2 1999
its a new battery and been on there for about 1 month and thanks for the welcome.
kwakzxr is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 07-02-2011, 03:08 AM
Post Master General
 
arron's Avatar
 
Join Date: Jul 2007
Location: melbourne
Posts: 11,637

I Ride: 1998 zx6r, 1999 sv650
Get a multi meter and see what it's putting out while it's running..




tinted screen, hel lines,intergrated tail light, rearset adjusters, K&N air filter, +4 advancer, -1 front, pazzo knock offs, ape cct, zip tie mod,07 shock + rear disk, 08 swingarm, vernhil rear line, 636 exhaust with dan moto cf can, Kleen air mod..

still lovin forever!
arron is offline  
post #5 of 6 Old 07-02-2011, 05:17 AM
Track Star
 
kbass808's Avatar
 
Join Date: Jun 2011
Location: Maui, Hawaii
Posts: 547

I Ride: 07 zx6r
might be grounding. Can get a additional unicharge. Its a lead you plug in when the bikes parked at home and recharges the battery. Had one on my Yamaha
kbass808 is offline  
post #6 of 6 Old 07-03-2011, 01:03 AM Thread Starter
Squid
 
Join Date: Jul 2011
Location: crawley, united kingdom
Posts: 3

I Ride: zx6rg2 1999
tried that its still not taking the charge
kwakzxr is offline  
Reply

  ZX6R Forum > ZX6R Forum > Mechanical and Technical

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP ! ! ! Charging system problems rocket The ZX6R 4 03-26-2013 02:18 AM
CHARGING PROBLEMS (i think) SoGone12 The ZX6R 34 03-26-2013 02:14 AM
Mores problems, clutch, shifter, and starting issues, HELP! Steel Mechanical and Technical 4 01-17-2012 12:08 AM
Couple of problems:( waynster Mechanical and Technical 11 07-28-2011 03:22 PM
Starting Problems zx6r 636 B1H 2004 Ninja_Jon The ZX6R 12 05-09-2009 11:44 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome