ZX600-G2 2000 MPH to KMH - ZX6R Forum
 6Likes
  • 1 Post By WildCard
  • 1 Post By RJ2112
  • 2 Post By Hakashi
  • 2 Post By WildCard
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 07-29-2019, 10:18 PM Thread Starter
Squid
 
Hakashi's Avatar
 
Join Date: Jul 2019
Posts: 2
Garage
Question ZX600-G2 2000 MPH to KMH

Hi guys,

Just bought a ZX600-G2 a 2000y. model.

The speedometer dial is in KMH but the needle works in MPH and its very disturbing, as I drive in Europe, I need KMH.



Just like this, I read the manual but there is no guide for MODE and RESET to switch it to KMH,

My guess is to change the speed sensor ? As I already tried another Speedometer...

thanks.
Hakashi is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-30-2019, 12:25 AM
World Superbike Racer
 
WildCard's Avatar
 
Join Date: Apr 2018
Location: Southwest Missouri
Posts: 1,377

I Ride: 2002 ZX-6R 2009 KLX 331 Supermoto
Garage
Looks like it's reading too fast, 160 mph would be 260 kph. Are you going that fast ?

I dont think the issue is that it is showing mph but that your speed sensor is shot.
Hakashi likes this.


Roads? Where we're going we don't need....

( _)

( _)>⌐■-■

(⌐■_■)

Roads. ☢

Last edited by WildCard; 07-30-2019 at 12:28 AM.
WildCard is offline  
post #3 of 5 Old 07-30-2019, 01:22 AM
Post Master General
 
RJ2112's Avatar
 
Join Date: Apr 2012
Location: Bowling Green, VA
Posts: 11,851

I Ride: '09 ZX6R
Might be an aftermarket 'Speedo healer' in line as well.... That could be failing, or making a correction for mph instead of kph.

Do you know if the bike has OEM final gearing? I'd guess 16 front, 43 rear?
Hakashi likes this.

"Basic stuff fellas. Use your head for something other than to break your next fall."
RJ2112 is online now  
Sponsored Links
Advertisement
 
post #4 of 5 Old 08-02-2019, 12:28 AM Thread Starter
Squid
 
Hakashi's Avatar
 
Join Date: Jul 2019
Posts: 2
Garage
Quote:
Originally Posted by WildCard View Post
Looks like it's reading too fast, 160 mph would be 260 kph. Are you going that fast ?

I dont think the issue is that it is showing mph but that your speed sensor is shot.
Apologies, I forgot to mention thats a pic from the internet

Quote:
Originally Posted by RJ2112 View Post
Might be an aftermarket 'Speedo healer' in line as well.... That could be failing, or making a correction for mph instead of kph.

Do you know if the bike has OEM final gearing? I'd guess 16 front, 43 rear?
Well the gears are all stock from my understanding.


Already changed the speedometer and the sensor, still the same, found a small adapter in between the sensor and the speedo last night, seems like a converter (Speedo healer), removed it but it was raining heavily, so had no time to test it out. Will try today

here is the picture of the thing, no number no ID, nothing, just a black sealed box.
https://i.imgur.com/y1rnK7Y.jpg


UPDATE: Just took it out, great weather, and the speedo is showing KMH! Finally that was the problem.
RJ2112 and WildCard like this.

Last edited by Hakashi; 08-03-2019 at 07:13 AM.
Hakashi is offline  
post #5 of 5 Old 08-02-2019, 07:20 PM
World Superbike Racer
 
WildCard's Avatar
 
Join Date: Apr 2018
Location: Southwest Missouri
Posts: 1,377

I Ride: 2002 ZX-6R 2009 KLX 331 Supermoto
Garage
Quote:
Originally Posted by Hakashi View Post
Apologies, I forgot to mention thats a pic from the internet



Well the gears are all stock from my understanding.


Already changed the speedometer and the sensor, still the same, found a small adapter in between the sensor and the speedo last night, seems like a converter (Speedo healer), removed it but it was raining heavily, so had no time to test it out. Will try today

here is the picture of the thing, no number no ID, nothing, just a black sealed box.
https://www.photobox.co.uk/my/photo/...d=502033881264


UPDATE: Just took it out, great weather, and the speedo is showing KMH! Finally that was the problem.

Glad it was a simple fix and you got it figured out.
RJ2112 and Hakashi like this.


Roads? Where we're going we don't need....

( _)

( _)>⌐■-■

(⌐■_■)

Roads. ☢
WildCard is offline  
Reply

  ZX6R Forum > ZX6R Forum > Mechanical and Technical

Tags
zx600-g2 zx600 g2

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome