Chinese ignition switch - ZX6R Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 07-12-2019, 01:35 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 7
Chinese ignition switch

Hey guys first time here, first time doing a bike build. 95 zx6r bought for less than nothing. It's in reasonable condition (unroadworthy) but has been left to rot for almost two years. Had to ditch the old ignition that had been taken to with an angle grinder. Bought a cheapo Chinese one but it's a standard 6 wire plug with an extra wire in the bundle where as mine is a 6 wire plug with only 5 wires. Wire Color used is totally different to stock plug. I was thinking that perhaps the plug was for a later model zx6r or even 9r. I'm hoping someone out in the Interweb thingy can give me a starting point to figure out what the extra wires are, and if the original wires will match up with their counterparts in the new plug. Cheers
Xceller6 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 07-12-2019, 02:24 AM
Squid
 
Topper's Avatar
 
Join Date: Apr 2019
Posts: 7
Found this if it's any help, ignition is in the top left.
Attached Thumbnails
Click image for larger version

Name:	IMG_0006_1562923410313.JPG
Views:	11
Size:	281.0 KB
ID:	94600  

Topper is offline  
post #3 of 11 Old 07-12-2019, 04:48 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 7
Cheers for the reply topper. Have already figured out from the manual what the wires and their relative slots in the plug are controlling am having issues with the aftermarket wiring on the new plug and the fact that it has extra wires. Are they just ad ons for extra things in later models or have wire positions of the original wires been altered as well ? Am having some other wiring issues as well and was just looking to RULE these out as the cause.
Xceller6 is offline  
Sponsored Links
Advertisement
 
post #4 of 11 Old 07-12-2019, 04:54 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 7
Actually topper thanks heaps mate. Didn't realise that I was looking at 7 wires there for a moment. What model is this from?
Xceller6 is offline  
post #5 of 11 Old 07-12-2019, 06:02 AM
Squid
 
Topper's Avatar
 
Join Date: Apr 2019
Posts: 7
Hi, says E3 on, which is the American 1995 model on but I would think it should be the same? Also noticed the wiring colours dont always match what's coming from the barrel which you mentioned?
Topper is offline  
post #6 of 11 Old 07-12-2019, 06:03 AM
Squid
 
Topper's Avatar
 
Join Date: Apr 2019
Posts: 7
Have you had no luck with getting it started?
Topper is offline  
post #7 of 11 Old 07-12-2019, 06:07 AM
Squid
 
Topper's Avatar
 
Join Date: Apr 2019
Posts: 7
I can see why why you didn't get one from the dealer lol £200 does seem a bit steep
Topper is offline  
post #8 of 11 Old 07-14-2019, 05:36 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 7
Ur right about the steep part mate. Near on $400 Over here for an oem. Considering the bike was free...... any way haven't had any luck as yet starting it. Found some other shit to fix whilst I was looking into the wiring. Cracked stator cover, leaking valve gasket, leaking sump gasket the list goes on. The manual says this bike is zx6r f3 'other than US or Canada' which I take to mean it's either a brit release or a grey import as Australia wiring doesnt match it either. Leaning towards grey. Wiring all matches up to the manual color wise and according to that im only meant to have the 5 wires coming out of the ignition so all seems as it should for now. With that diagram you gave me i should be able to nut it out. Seems theres an xtra ignition wire in there for a start.
Xceller6 is offline  
post #9 of 11 Old 07-14-2019, 05:43 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 7
No just figured it. Its the last white and yellow wire i dont have. Battery and tl3. Means a plug rewire but i think i can manage. Thanks again for the diagram mate
Xceller6 is offline  
post #10 of 11 Old 07-23-2019, 04:14 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 7
Magicdave
Attached Thumbnails
Click image for larger version

Name:	20190723_185156_1563880333971.jpg
Views:	2
Size:	2.46 MB
ID:	94732  

Xceller6 is offline  
post #11 of 11 Old 07-23-2019, 04:54 AM
Squid
 
MaGiCdAvE's Avatar
 
Join Date: May 2016
Location: Plymouth, Devon
Posts: 43

I Ride: ZX6R 636 2002 model
if i dismantle the chinese one we should be able to compare colours
MaGiCdAvE is offline  
Reply

  ZX6R Forum > ZX6R Forum > Mechanical and Technical

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome